Меню

Настройка маршрутизация сети cisco



Как настроить маршрутизатор cisco / Организация сети для небольшого офиса

Как настроить маршрутизатор cisco / Организация сети для небольшого офиса

Как настроить маршрутизатор cisco

Всем привет сегодня хочу рассказать вам, как настроить маршрутизатор ciscoили организовать сеть для небольшого офиса. Поговорим об отличиях коммутатора 3 уровня и маршрутизатора, и разберем схему организации малого офиса и среднего, с использованием роутера Cisco. Думаю это интересная тема и весьма часто встречающаяся.

Отличия роутера Cisco от коммутатора 3 уровня

Напомню в предыдущей статье мы настроили коммутатор cisco в качестве ядра, работающего на 3 уровне модели OSI, и разобрали, что он производительнее и дешевле, чем router cisco. Так, что же тогда заставляет покупать маршрутизаторы Cisco, все дело в мозгах, которые дают функционал, такой как:

Без которого сложно представить как связывать удаленные офисы с центральным. Такая вот хитрая политика партии у Cisco.

Схема для малого офиса

Схема филиала такая: 1 роутер Router0 модели Cisco 1841 для примера, один коммутатор Cisco 2960 и три компьютера. Как видите у нас есть 3 сегмента, для которых мы настроим vlan. Предполагается, что у вас уже произведена базовая настройка коммутатора Cisco.

Создаем VLAN2, VLAN3, VLAN4. Логинимся на ваш cisco 2960 и переходим в режим конфигурирования/

теперь определим каждый компьютер в нужный vlan. PC0 в vlan 2, PC1 в vlan 3, PC2 в vlan 4. У меня это порты fa0/1, fa0/2 и fa0/3.

Следующим шагом будет настроить trunk порт до нашего роутера Cisco 1841. Вводим следующие команды

Выбираем нужный интерфейс

Выставляем режим trunk

разрешаем определенные vlan

Все работы на коммутаторе Cisco 2960 закончены, переходим к нашему роутеру.

Настройка маршрутизатор cisco 1841

Начнем настраивать маршрутизатор cisco 1841, для того чтобы он маршрутизировал трафик между vlan и был в качестве интернет шлюза. По умолчанию все порты на маршрутизаторе находятся в выключенном состоянии, включим порт куда воткнут патчкорд от коммутатора cisco 2960, у меня это fa 0/0.

У вас появится нечто подобное, сообщая вам что порт стал быть активным.

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Порт стал зеленым

Следующим шагом нужно создать сабъинтерфейсы по количеству vlan. У роутеров просто нет vlan и их роль выполняют сабъинтерфейсы, где определенному vlan соответствует subinerface.

Создаем subinterface для vlan 2

указываем что он относится и случает пакеты vlan 2

настраиваем ip адрес

и сохраняем настройки командой

Настроим подобный образом subinterface для vlan 3,4

ip routing
do wr mem

Пробуем пропинговать с компьютера PC0 компьютер PC3 и PC2. Как видим на скриншоте все ок.

Вот так вот просто организовать локальную сеть в очень небольшом филиале и где быстро производится настройка маршрутизатора cisco. настройку NAT мы произведем в другой статье.

Схема для среднего офиса

Вот как выглядит схема локальной сети среднего офиса. Есть маршрутизатор cisco 2911, выступающий в роли интернет шлюза. Есть ядро сети коммутатор 3 уровня Cisco 3560. Он будет маршрутизировать локальный трафик между vlan сети. В Cisco 3560 воткнуты 3 коммутатора второго уровня Cisco 2960, которые уже подключают в себя конечные устройства. В сети есть 3 vlan 2,3,4.

Настройка Switch1

Начнем с настройки Switch1, сегмента серверов. Логинимся в режим глобальной конфигурации.

Закинем порты fa 0/1-2 в VLAN4

Настроим trunk порт fa 0/3, разрешать будем только трафик vlan4

Настройка Switch2

Все с сегментом серверов мы закончили. Переходим к такой же настройке на Switch2 и 3. И так Switch2 Cisco 2960.

Первым делом создаем vlan 2 и vlan3.

Теперь определим наши порты в которые подключены компьютеры в нужные vlan

Настроим trunk порт на интерфейсе fa 0/3

Настройка Switch3

Тот же фокус проводим с настройкой Switch3 Cisco 2960

Первым делом создаем vlan 2 и vlan3.

Теперь определим наши порты в которые подключены компьютеры в нужные vlan

Настроим trunk порт на интерфейсе fa 0/3

Настройка ядра сети

Приступаем к настройке маршрутизации, на ядре Cisco 3560, все три его порта нужно настроить как trunk, создать vlan и назначить им ip.

Читайте также:  Где на компьютере найти настройки беспроводной сети

создаем vlan 2,3,4
vlan 2
name VLAN2
exit
vlan 3
name VLAN3
exit
vlan 4
name VLAN4
exit

Задаем статический ip адрес vlan2,3,4

int vlan 2
ip address 192.168.1.251 255.255.255.0
no shutdown
exit
int vlan 3
ip address 192.168.2.251 255.255.255.0
no shutdown
exit
int vlan 4
ip address 192.168.3.251 255.255.255.0
no shutdown
exit

Настраиваем trunk порты

int fa 0/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 2,3
exit
int fa 0/2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 2,3
exit
int fa 0/3
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 2,3
exit

Включаем маршрутизацию и сохраняем конфигурацию
ip routing
do wr mem

Ping будет производиться с компьютера PC3. Как видим, сервера и обычные компьютеры разделены.

О настройке интернета и NAT поговорим в следующих статьях на данную тему. Как видите конфигурирование маршрутизаторов cisco, не такое уж и сложное дело.

Источник

Статическая маршрутизация Cisco

Статическая маршрутизация Cisco

Всем привет сегодня мы с вами поговорим про такую вещь как статическая маршрутизация в оборудовании Cisco. Эта статья продолжение поста Как настроить маршрутизатор cisco / Организация сети для небольшого офиса. Там мы настроили локальную сеть в двух офисах компании, один маленький офис, второй чуть побольше. На роутере во втором офисе мы остановились на настройке статической маршрутизации, чем мы и займемся.

Таблица маршрутизации

Первое с чем нужно познакомиться, это с понятием таблицы маршрутизации. Если в двух словах это некая карта маршрутов, до сетей о которых знает ваш коммутатор 3 уровня или роутер. Для большей наглядности ее можно сравнить с картой дорог до городов России. И для того, чтобы например мне попасть из Москвы в Нижний Новгород, я должен выбрать определенную дорогу. Так и ваш роутер выбирает ее. Далее если мне нужно из Москвы попасть в Казань, и мне нужно ехать туда через Нижний Новгород, то В НН должен быть свой маршрут до Казани и так далее.

Статический маршрут — это постоянный неизменный маршрут, чаще всего прописанный в ручную.

Схема сети офисов

У нас есть филиал, в котором 3 компьютера коммутатор второго уровня Cisco 2960 и Роутер Cisco 1841, есть три vlan (2,3,4). Есть главный офис в котором есть 5 vlan (2,3,4,5), маршрутизацией локального трафика занимается ядро в виде коммутатора 3 уровня Cisco 3560, который VLAN 5 подключен к роутеру Cisco 2911, на котором настроен будет интернет и канал до филиала.

В предыдущем посте где мы создавали данную локальную сеть я не настроил vlan 5 на роутере и ядре, исправим это.

Настройка Cisco 2911 и Cisco 3560

Настройка Cisco 3560

Создаем Vlan 5
vlan 5
name VLAN5
exit

Настроим ip адрес VLAN5
int vlan 5
ip address 192.168.5.1 255.255.255.0
exit

Добавим порт gi1/1 в VLAN5
int gi0/1

выставляем режим доступа
switchport mode access
switchport access vlan 5
no shutdown
do wr mem

Настройка Cisco 2911

Так как у нас локальной маршрутизацией трафика занимается ядро то тут sub интерфейсов создавать не нужно. Настроим порт роутера gi0/0 на vlan5.

Добавление статических маршрутов на Cisco 2911

Так как наш роутер Cisco 2911 ничего не знает о сетях 192.168.1.0, 192.168.2.0, 192.168.3.0, то нужно задать ему статические маршруты до них, через ядро делается это следующим образом.

Удостоверимся что пинг не проходит до компьютера 192.168.1.1, вводим на роутере.

Видим ответов нет

Переходим в режим конфигурирования командой

и смотрим команду ip:

access-list Named access-list

cef Cisco Express Forwarding

default-gateway Specify default gateway (if not routing IP)

default-network Flags networks as candidates for default routes

dhcp Configure DHCP server and relay parameters

domain IP DNS Resolver

domain-lookup Enable IP Domain Name System hostname translation

domain-name Define the default domain name

flow-export Specify host/port to send flow statistics

forward-protocol Controls forwarding of physical and directed IP broadcasts

ftp FTP configuration commands

Читайте также:  Debian настройка сети прокси

host Add an entry to the ip hostname table

local Specify local options

name-server Specify address of name server to use

nat NAT configuration commands

route Establish static routes

routing Enable IP routing

ssh Configure ssh options

tcp Global TCP parameters

Нам нужна команда ip route.

так как ip адрес на ядре сети (Cisco 3560) у VLAN 5 у нас 192.168.5.1 то он будет выступать для нас шлюзом. В итоге пишем.

и выполнив теперь команду Ping мы видим. что пакет дошел до 192.168.1.1

Планирование сети

Все бы хорошо, но мы не правильно спланировали сеть в удаленном офисе. Так как там как и в главном, тоже есть сеть 192.168.1.0, 192.168.2.0, 192.168.3.0, такого быть не должно иначе получается дубли. Как правильно планировать сеть я писал тут, вам нужно перенастроить, как ранее описано в предыдущей статье. В итоге в филиале я заменил сети на 11, 22, 33 третьи актеты ip адреса. Общая картина теперь выглядит так.

Соединение роутеров

Соединяем наши роутеры. Предположим, что между ними есть прямой линк, в жизни конечно это VPN канал. настроим в начале роутер Cisco 2911 в главном офисе.

маска тут 32 бита так как нам достаточно всего 2 ip адреса.

Теперь настроим роутер Cisco 1841 в филиале. У меня это интерфейс fa0/1

У нас загорелись порты обоих коммутаторов.

Проверяем пинги с роутеров друг до друга

Видим, что все успешно.

Настройка маршрутов между роутерами

Пробуем например с роутера в филиале пропинговать компьютер 192.168.1.1, и естественно пинг не пройдет так как нет маршрутов, чем мы и займемся. Так как у нас один шлюз соединения между офисами, то правильнее будет прописать один дефолтный путь, но можно и прописывать конкретный статический маршрут, например если основной шлюз интернет и весь трафик по умолчанию идет туда и вы хотите на конкретную сеть завернуть через другой шлюз.

но если бы нужно было прописать ручками каждый то вот так

ip route 192.168.1.0 255.255.255.0 192.168.100.1

ip route 192.168.2.0 255.255.255.0 192.168.100.1

ip route 192.168.3.0 255.255.255.0 192.168.100.1
do wr mem

Настроим теперь роутер у главного офиса, нам нужно добавить маршруты до сетей 192.168.11.0, 192.168.22.0, 192.168.33.0.

либо если нужно в ручную отдельным маршрутом.

Настройка маршрутов на ядре

Напомню, что локальный трафик маршрутизирует ядро сети коммутатор 3 уровня Cisco 3560, и на нем нужно тоже указать маршруты, до филиала. В качестве шлюза указывается, ip адрес vlan5 на роутере 2911 192.168.5.251

Вот финальный вид нашей филиальной сети.

Берем теперь компьютер из филиала с ip адресом 192.16811.1 и пробуем с него пропинговать 192.168.1.1 для примера. И видим, что все отлично пингуется, значит связь между офисами есть.

Посмотреть таблицу маршрутизации на Cisco можно командой

Где буква C означает что соединение установлено, буква S означает что маршрут статический.

Вот так вот просто объединить офисы в одну сеть, мы с вами разобрались со статической маршрутизацией, рассмотрели ее на примерах. В организации тестового стенда мне помог симулятор, Скачать Cisco packet tracer можно тут. На этом все.

Популярные Похожие записи:

9 Responses to Статическая маршрутизация Cisco

Спасибо за статью.

Помогите разобраться с маршрутизацией и настроить доступ к локальным сетям:
Есть три здания:
Здание1 IP-адрес внешний 10.135.13.129 Маска 255.255.255.128 IP-адрес внутренний 150.150.2.3 Маска 255.255.0.0

Здание 2 IP-адрес внешний 10.135.59.1 Маска 255.255.255.128 IP-адрес внутренний 192.168.30.1 Маска 255.255.255.0

Здание 3 IP-адрес внешний 10.135.67.1 Маска 255.255.255.128 IP-адрес внутренний 192.168.0.1 Маска 255.255.255.0

Ping между роутерами Cisco по внешним адресам есть

У меня вот такое предположение:

ip route 192.168.30.0 255.255.255.0 10.135.13.129

ip route 192.168.0.0 255.255.255.0 10.135.13.129

ip route 150.150.0.0 255.255.0.0 10.135.59.1

ip route 192.168.0.0 255.255.255.0 10.135.59.1

ip route 150.150.0.0 255.255.0.0 10.135.67.1

ip route 192.168.30.0 255.255.255.0 10.135.67.1

Ping к компьютерам из внутренних сетей не проходит.

а по трассировкам куда трафик идет?

Трассировка до яндекса

Трассировка маршрута к YA.ru [213.180.193.3]
с максимальным числом прыжков 30:

Хотя по логике должно быть так:

Читайте также:  Настройка и подключение проводной локальной сети

Route -p add 192.168.30.0 mask 255.255.255.0 10.135.59.1

Route -p add 192.168.0.0 mask 255.255.255.0 10.135.67.1

Route -p add 150.150.0.0 mask 255.255.0.0 10.135.13.129

Route -p add 192.168.0.0 mask 255.255.255.0 10.135.67.1

Route -p add 150.150.0.0 mask 255.255.0.0 10.135.13.129

Route -p add 192.168.30.0 mask 255.255.255.0 10.135.59.1

Нашел ошибку(мешали остатки настроек от прошлого хозяина) теперь трессеровка вот так выглядит:

Трассировка маршрута к 192.168.30.1 с максимальным числом прыжков 30

Алексей извините, что не ответил, отсутствовал по уважительной причине, сын родился 🙂 Рад, что вы нашли у себя причину проблемы.

Про маршрутизацию всё рассказали и показали, а вот доступ к Интернету, что-то упустили,хотелось бы по подробнее, или я что-то не увидел? =)

…маска тут 32 бита так как нам достаточно всего 2 ip адреса
ip address 192.168.100.1 255.255.255.252

Источник

Статическая маршрутизация на Cisco

Давайте продебажим это дело, отследив путь пакетов.
debug ip packet — служит для активации дебаг-лога
Запускаем её на обоих маршрутизаторах и снова запустим пинги с 172.20.20.100 до 192.168.100.2.
Сначала левый.

В первой строчке видим, что на него пришел пакет от 172.20.20.100, направляемый на адрес 192.168.100.2. А слово forward во второй строчке означает, что этот пакет был передан дальше.
Теперь взглянем на правый роутер.

Пакет сюда всё же добрался, но дальше целевой хост должен отправить ответ с интерфейса 192.168.100.2 на 172.20.20.100, вот только наш маршрутизатор понятия не имеет о сети 172.20.20.0/16 и как в неё стучаться. Мы пока не задавали шлюз по-умолчанию (default gateway), поэтому видим в логе слово unroutable.
Вырубаем дебаг-режим командой no debug ip packet, а если хотите их посмотреть, то скажите show debugging.
Сеть у нас маленькая, поэтому самым простым и логичным способом настроить маршрутизацию будет добавление так называемого маршрута по-умолчанию (default route). Для этого левому маршрутизатору скажем следующее:

Синтаксис здесь такой:
ip route [IP сети назначения] [её маска] [IP интерфейса, на которые надо перенаправить пакеты, чтобы попасть в данную сеть]
Маршрут с IP 0.0.0.0 и маской 0.0.0.0 становится маршрутом по-умолчанию, на который уйдут все пакеты адреса назначения которых прямо отсутствуют в таблице маршрутизации (routing table).
Давайте пример. Вот хотим мы пингануть с ПК 192.168.1.100 хост с IP адресом 10.10.10.100. Шлюз по-умолчанию (default gateway) у нашего ПК с IP 192.168.1.100192.168.1.1. ПК попробует найти в своей таблице маршрутизации IP 10.10.10.100, зафейлит и решит поискать маршрут до сети 10.0.0.0/8 в целом. Это ему также не удастся и он отправит пакет на шлюз по-умолчанию, тот самый 192.168.1.1. Роутер также сначала поищет путь до 10.10.10.100, потом будет рыскать в своей таблице маршрутизации в поисках маршрута до подсети 10.0.0.0/8, но и тут ничего не отыщет. Зато обнаружит прописанный маршрут по-умолчанию, и с радостью отправит пакет на 192.168.100.2, переложив поиск маршрута на другой маршрутизатор. Прямой путь до 10.10.10.100 он, конечно, не найдет, зато увидит информацию по сети 10.0.0.0/8, оказывается адресованные туда пакеты следует слать на интерфейс FastEthernet0/1, именно к которому эта сеть и подключена (directly connected). У нас для простоты роль подсети играет единственный хость 10.10.10.100 и пакет попадет к нему. Дальше всё пойдет в обратном порядке, только с назначением на 192.168.1.100/24.
Маршрутом по-умолчанию удается отделаться далеко не всегда. Чаще приходится прописывать маршруты для каждой сети в отдельности. Разберемся как это делается, но сначала выпилим то, что уже имеется в таблице маршрутизации:
no ip route xxxx(адрес сети) yyyy(маска) zzzz(адрес интерфейса)
В итоге таблица должна содержать только информацию о непосредственно подключенных к маршрутизатору сетях. Левый роутер будет выглядеть так:

Теперь просто добавим на каждый из маршрутизаторов рауты к сетям, которые им неизвестны.
Левому:

В итоге всё будет работать в соответствии с данной схемой:

Даже в такой сети пришлось добавить довольно много информации по маршрутам, а что делать, когда маршрутизаторов три/пять/десять? Тогда на помощь нам придет динамическая маршрутизация, но об этом в другой раз.

Источник

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Adblock
detector