Меню

Настройка mikrotik почтовый сервер



ИТ База знаний

Курс по Asterisk

Полезно

— Узнать IP — адрес компьютера в интернете

— Онлайн генератор устойчивых паролей

— Онлайн калькулятор подсетей

— Калькулятор инсталляции IP — АТС Asterisk

— Руководство администратора FreePBX на русском языке

— Руководство администратора Cisco UCM/CME на русском языке

— Руководство администратора по Linux/Unix

Навигация

Серверные решения

Телефония

FreePBX и Asterisk

Настройка программных телефонов

Корпоративные сети

Протоколы и стандарты

Популярное и похожее

Настройка PPTP клиента на Mikrotik

Мониторим MikroTik с помощью Zabbix по SNMP

Гайд по MikroTik Fetch

Настройка VLAN в Mikrotik

Легкая настройка NTP на Mikrotik

Настройка DHСP сервера на Mikrotik

Все про трафик с Netflow на MikroTik

Fanvil X6

Еженедельный дайджест

Настройка отправки email с MikroTik

3 минуты чтения

Рассказываем про ещё один полезный инструмент на роутерах MikroTik — отправку e-mail сообщений по протоколу SMTP. Данный инструмент может быть использован для отправки на почту периодических бэкапов или же задействован для написания каких-нибудь скриптов.

  • В интерфейсе WinBox, утилита Email расположена в разделе ToolsEmail:

  • Из командной строки — /tool e-mail .

    Первым делом нужно настроить сервер исходящей почты по протоколу SMTP. Доступны следующие параметры настройки:

    • address — IPv4/v6 адрес, SMTP сервера;
    • from — имя или название почтового ящика, который будет показан получателю;
    • password — пароль, который используется для аутентификации на SMTP сервере. В этом случае аутентификации не будет шифроваться. Для включения шифрования можно использовать функцию start-tls;
    • port — порт SMTP сервера, по умолчанию 25;
    • start-tls — может принимать значения no, yes и tls-only — разрешает только TLS шифрования без поддержки SSL;
    • user — имя пользователя, которое будет использоваться для аутентификации на SMTP сервере.

    Когда сервер будет настроен, можно начинать отправлять письма. Все параметры при отправке писем идут после команды /tool e-mail send:

    • body — тело письма
    • cc — данный параметр позволяет поставить в копию дополнительных получателей;
    • file — позволяет добавлять один или несколько файлов во вложении к письму;
    • from — название или почтовый адрес, который будет показан как отправитель. Если ничего не указано, то будет взят from, который указывался при настройке сервера SMTP;
    • password — пароль, который используется для аутентификации на SMTP сервере. Если ничего не указано, то будет взят password, который указывался при настройке сервера SMTP;
    • port — порт SMTP сервера. Если ничего не указано, то будет взят port, который указывался при настройке сервера;
    • server — адрес SMTP сервера. Если не указано, то используется параметр сервера, указанный при настройке;
    • start-tls — использовать ли TLS шифрование;
    • subject — тема письма;
    • to — адрес получателя, которому предназначено письмо;
    • user — имя пользователя, для аутентификации на сервере. Если не указано, то будет использоваться user из настроек сервера.

    Теперь давайте применим механизм отправки писем на практике и создадим скрипт, который будет каждый день высылать файл с резервной копией конфигурации нам на почту.

    Вот как настройка будет выглядеть в командной строке:

    Теперь добавим новый скрипт, который будет делать бэкап конфигурации роутера:

    Добавим скрипт на выгрузку конфигурации в планировщик:

    Готово, теперь каждый день нам на почту mnadmin@mndomain.ru будет приходить свежая выгрузка резервной копии конфигурации нашего роутера.

    Для того, чтобы настроить отправку писем на почтовый ящик, требующий TLS шифрования (как например Google mail), нужно настроить следующие параметры отправителя:

    При отправке письма на такой ящик, необходимо указать параметр start-tls.

    Если Вы предпочитаете настраивать роутер с помощью интерфейса WinBox, то откройте ToolsEmail и настройте параметры сервера:

    Далее заходим в SystemScripts и добавляем новый скрипт на выгрузку конфигурации:

    Добавляем скрипт в планировщик, чтобы он срабатывал каждый день:

    Источник

    Настройка отправки email с MikroTik

    Рассказываем про ещё один полезный инструмент на роутерах MikroTik — отправку e-mail сообщений по протоколу SMTP. Данный инструмент может быть использован для отправки на почту периодических бэкапов или же задействован для написания каких-нибудь скриптов.

    • В интерфейсе WinBox, утилита Email расположена в разделе ToolsEmail :
    • Из командной строки — /tool e-mail.

    Первым делом нужно настроить сервер исходящей почты по протоколу SMTP. Доступны следующие параметры настройки:

    • address — IPv4/v6 адрес, SMTP сервера;
    • from — имя или название почтового ящика, который будет показан получателю;
    • password — пароль, который используется для аутентификации на SMTP сервере. В этом случае аутентификации не будет шифроваться. Для включения шифрования можно использовать функцию start-tls;
    • port — порт SMTP сервера, по умолчанию 25;
    • start-tls — может принимать значения no, yes и tls-only — разрешает только TLS шифрования без поддержки SSL;
    • user — имя пользователя, которое будет использоваться для аутентификации на SMTP сервере.

    Когда сервер будет настроен, можно начинать отправлять письма. Все параметры при отправке писем идут после команды /tool e-mail send:

    • body — тело письма
    • cc — данный параметр позволяет поставить в копию дополнительных получателей;
    • file — позволяет добавлять один или несколько файлов во вложении к письму;
    • from — название или почтовый адрес, который будет показан как отправитель. Если ничего не указано, то будет взят from, который указывался при настройке сервера SMTP;
    • password — пароль, который используется для аутентификации на SMTP сервере. Если ничего не указано, то будет взят password, который указывался при настройке сервера SMTP;
    • port — порт SMTP сервера. Если ничего не указано, то будет взят port, который указывался при настройке сервера;
    • server — адрес SMTP сервера. Если не указано, то используется параметр сервера, указанный при настройке;
    • start-tls — использовать ли TLS шифрование;
    • subject — тема письма;
    • to — адрес получателя, которому предназначено письмо;
    • user — имя пользователя, для аутентификации на сервере. Если не указано, то будет использоваться user из настроек сервера.

    Теперь давайте применим механизм отправки писем на практике и создадим скрипт, который будет каждый день высылать файл с резервной копией конфигурации нам на почту.

    Вот как настройка будет выглядеть в командной строке:

    tool e-mail> set server=192.168.1.34 set port=25 from=”mnmikrotik@mndomain.ru”

    Теперь добавим новый скрипт, который будет делать бэкап конфигурации роутера:

    /export file=export /tool e-mail send to=»mnadmin@mndomain.ru»subject=»$[/system identity get name] export» \ body=»$[/system clock get date] configuration file» file=export.rsc

    Добавим скрипт на выгрузку конфигурации в планировщик:

    /system scheduler add on-event=»export-send» start-time=00:00:00 interval=24

    Готово, теперь каждый день нам на почту mnadmin@mndomain.ru будет приходить свежая выгрузка резервной копии конфигурации нашего роутера.

    Для того, чтобы настроить отправку писем на почтовый ящик, требующий TLS шифрования (как например Google mail), нужно настроить следующие параметры отправителя:

    /tool e-mail set address= 192.168.1.34
    set port=587
    set from=mnaddress@gmail.com
    set user= mikrotik
    set password= supersecurepass

    При отправке письма на такой ящик, необходимо указать параметр start-tls.

    send to=mnadmin@mndomain.ru subject=»HW!» body=»Hello World!» start-tls=yes

    Если Вы предпочитаете настраивать роутер с помощью интерфейса WinBox, то откройте ToolsEmail и настройте параметры сервера:

    Далее заходим в SystemScripts и добавляем новый скрипт на выгрузку конфигурации:

    Добавляем скрипт в планировщик, чтобы он срабатывал каждый день:

    Источник

    Настройка mikrotik почтовый сервер

    Настройка оборудования MikroTik

    Резервирование, агрегация, VPN, скрипты для решения нестандартных задач.

    Песочница. Проброс портов для E-mail сервера.

    Правила форума
    Как правильно оформить вопрос.
    Прежде чем начать настройку роутера, представьте, как это работает. Попробуйте почитать статьи об устройстве интернет-сетей. Убедитесь, что всё, что Вы задумали выполнимо вообще и на данном оборудовании в частности.
    Не нужно изначально строить Наполеоновских планов. Попробуйте настроить простейшую конфигурацию, а усложнения добавлять в случае успеха постепенно.
    Пожалуйста, не игнорируйте правила русского языка. Отсутствие знаков препинания и неграмотность автора топика для многих гуру достаточный повод проигнорировать топик вообще.

    1. Назовите технологию подключения (динамический DHCP, L2TP, PPTP или что-то иное)
    2. Изучите темку «Действия до настройки роутера».
    viewtopic.php?f=15&t=2083
    3. Настройте согласно выбранного Вами мануала
    4. Дочитайте мануал до конца и без пропусков, в 70% случаев люди просто не до конца читают статью и пропускают важные моменты.
    5. Если не получается, в Winbox открываем терминал и вбиваем там /export hide-sensitive. Результат в топик под кат, интимные подробности типа личных IP изменить на другие, пароль забить звездочками.
    6. Нарисуйте Вашу сеть, рисунок (схему) сюда. На словах может быть одно, в действительности другое.

    Здравствует !
    Я купил и осознавал, что я покупаю СТАБИЛЬНОСТЬ роутер Mikrotik RB951

    Имеется почтовый сервер iRedMail на Centose 7 — поднял, настроил работает ( сертификаты, учетки и т д ) все норм.

    купил белый IP.
    подключил его в 4 порт
    его адрес прописан на карточке 192.168.0.15

    в НАТе указал порты проброса ДС-НАТ 25,587,110,995,143,993,465 на ip 192.168.0.15

    письма уходят и доходят до адресата, но не приходят ответы т.е. письма не приходят.

    где что пропустил ?

    P.S.: интернет по рррое на 1 порту

    Nat вот так выглядит:

    add action=dst-nat chain=dstnat dst-port=25 log=yes log-prefix=»===EM25===» protocol=tcp to-addresses=192.168.0.15 to-ports=25
    add action=dst-nat chain=dstnat dst-port=465 log=yes log-prefix=»===EM465===» protocol=tcp to-addresses=192.168.0.15 to-ports=465
    add action=dst-nat chain=dstnat dst-port=587 log-prefix=»===EM587==» protocol=tcp to-addresses=192.168.0.15 to-ports=587
    add action=dst-nat chain=dstnat dst-port=995 log=yes log-prefix=»===EM995===» protocol=tcp to-addresses=192.168.0.15 to-ports=995
    add action=dst-nat chain=dstnat dst-port=110 log=yes log-prefix=»===EM110===» protocol=tcp to-addresses=192.168.0.15 to-ports=110
    add action=dst-nat chain=dstnat dst-port=143 log=yes log-prefix=»===EM143===» protocol=tcp to-addresses=192.168.0.15 to-ports=143
    add action=dst-nat chain=dstnat dst-port=993 log=yes log-prefix=»===EM993===» protocol=tcp to-addresses=192.168.0.15 to-ports=993

    P.S.1: с мобильного телнетом проверял порты отвечают, так же телнетом на майл пробивался на 25 порт проходит

    1) Надо в NAT правила добавить либо dst-address=ваш_внешний-адрес либо in-interface=ваш_внешний_интерфейс в зависимости от того, что лучше подходит по логике, иначе получается, что роутер вообще все пакеты по данным портам перенаправляет на 192.168.0.15
    2) В firewall’е есть правило разрешающее все то же самое?
    Или вообще глобальное, которое разрешает всё, что было подвергнуто dst-nat?

    И ещё пару замечаний:
    3) если в NAT правиле порт не меняется, его можно не указывать.
    4) если не нужна будет статистика по пакетам по каждому порту, это все можно одним правилом описать:

    Источник

    Открыть порт для почты (почтового клиента) на микротик.

    Все новые темы

Список форумов SYSAdmins.RU -> NETWORKS На страницу Пред. 1, 2, 3 След.
Автор
Хвостатос
Новичок

Зарегистрирован: 21.10.2015
Пользователь #: 158,696
Сообщения: 52


Голоса: 3

Добавлено: Ср 09 Окт, 2019 11:06 Заголовок сообщения:
Вернуться к началу
Зарегистрируйтесь и реклама исчезнет!

Andrei9385
[+]

Зарегистрирован: 31.10.2018
Пользователь #: 169,774
Сообщения: 473


Голоса: 7

Добавлено: Ср 09 Окт, 2019 11:09 Заголовок сообщения:
Вернуться к началу
Хвостатос
Новичок

Зарегистрирован: 21.10.2015
Пользователь #: 158,696
Сообщения: 52


Голоса: 3

Добавлено: Ср 09 Окт, 2019 11:11 Заголовок сообщения:
Вернуться к началу
Andrei9385
[+]

Зарегистрирован: 31.10.2018
Пользователь #: 169,774
Сообщения: 473


Голоса: 7

Добавлено: Ср 09 Окт, 2019 11:16 Заголовок сообщения:
Вернуться к началу
Хвостатос
Новичок

Зарегистрирован: 21.10.2015
Пользователь #: 158,696
Сообщения: 52


Голоса: 3

Добавлено: Ср 09 Окт, 2019 11:18 Заголовок сообщения:
Вернуться к началу
Хвостатос
Новичок

Зарегистрирован: 21.10.2015
Пользователь #: 158,696
Сообщения: 52


Голоса: 3

Добавлено: Ср 09 Окт, 2019 11:20 Заголовок сообщения:
Вернуться к началу
Хвостатос
Новичок

Зарегистрирован: 21.10.2015
Пользователь #: 158,696
Сообщения: 52


Голоса: 3

Добавлено: Ср 09 Окт, 2019 11:28 Заголовок сообщения:
Вернуться к началу
Андрай
[+][+]

Зарегистрирован: 24.03.2008
Пользователь #: 68,166
Сообщения: 370
Откуда: СПб

Голоса: 4

Добавлено: Ср 09 Окт, 2019 11:32 Заголовок сообщения:
Вернуться к началу
Maded
Новичок

Зарегистрирован: 09.08.2006
Пользователь #: 41,071
Сообщения: 77
Откуда: msk

Добавлено: Ср 09 Окт, 2019 11:33 Заголовок сообщения:
_________________
MTCNA,MTCRE,MTCWE
Вернуться к началу
Хвостатос
Новичок

Зарегистрирован: 21.10.2015
Пользователь #: 158,696
Сообщения: 52

Источник

Читайте также:  Домашний медиа сервер настройка sharp