Меню

Настройка роутера cisco 3925



Как настроить маршрутизатор cisco / Организация сети для небольшого офиса

Как настроить маршрутизатор cisco / Организация сети для небольшого офиса

Как настроить маршрутизатор cisco

Всем привет сегодня хочу рассказать вам, как настроить маршрутизатор ciscoили организовать сеть для небольшого офиса. Поговорим об отличиях коммутатора 3 уровня и маршрутизатора, и разберем схему организации малого офиса и среднего, с использованием роутера Cisco. Думаю это интересная тема и весьма часто встречающаяся.

Отличия роутера Cisco от коммутатора 3 уровня

Напомню в предыдущей статье мы настроили коммутатор cisco в качестве ядра, работающего на 3 уровне модели OSI, и разобрали, что он производительнее и дешевле, чем router cisco. Так, что же тогда заставляет покупать маршрутизаторы Cisco, все дело в мозгах, которые дают функционал, такой как:

Без которого сложно представить как связывать удаленные офисы с центральным. Такая вот хитрая политика партии у Cisco.

Схема для малого офиса

Схема филиала такая: 1 роутер Router0 модели Cisco 1841 для примера, один коммутатор Cisco 2960 и три компьютера. Как видите у нас есть 3 сегмента, для которых мы настроим vlan. Предполагается, что у вас уже произведена базовая настройка коммутатора Cisco.

Создаем VLAN2, VLAN3, VLAN4. Логинимся на ваш cisco 2960 и переходим в режим конфигурирования/

теперь определим каждый компьютер в нужный vlan. PC0 в vlan 2, PC1 в vlan 3, PC2 в vlan 4. У меня это порты fa0/1, fa0/2 и fa0/3.

Следующим шагом будет настроить trunk порт до нашего роутера Cisco 1841. Вводим следующие команды

Выбираем нужный интерфейс

Выставляем режим trunk

разрешаем определенные vlan

Все работы на коммутаторе Cisco 2960 закончены, переходим к нашему роутеру.

Настройка маршрутизатор cisco 1841

Начнем настраивать маршрутизатор cisco 1841, для того чтобы он маршрутизировал трафик между vlan и был в качестве интернет шлюза. По умолчанию все порты на маршрутизаторе находятся в выключенном состоянии, включим порт куда воткнут патчкорд от коммутатора cisco 2960, у меня это fa 0/0.

У вас появится нечто подобное, сообщая вам что порт стал быть активным.

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Порт стал зеленым

Следующим шагом нужно создать сабъинтерфейсы по количеству vlan. У роутеров просто нет vlan и их роль выполняют сабъинтерфейсы, где определенному vlan соответствует subinerface.

Создаем subinterface для vlan 2

указываем что он относится и случает пакеты vlan 2

настраиваем ip адрес

и сохраняем настройки командой

Настроим подобный образом subinterface для vlan 3,4

ip routing
do wr mem

Пробуем пропинговать с компьютера PC0 компьютер PC3 и PC2. Как видим на скриншоте все ок.

Вот так вот просто организовать локальную сеть в очень небольшом филиале и где быстро производится настройка маршрутизатора cisco. настройку NAT мы произведем в другой статье.

Схема для среднего офиса

Вот как выглядит схема локальной сети среднего офиса. Есть маршрутизатор cisco 2911, выступающий в роли интернет шлюза. Есть ядро сети коммутатор 3 уровня Cisco 3560. Он будет маршрутизировать локальный трафик между vlan сети. В Cisco 3560 воткнуты 3 коммутатора второго уровня Cisco 2960, которые уже подключают в себя конечные устройства. В сети есть 3 vlan 2,3,4.

Настройка Switch1

Начнем с настройки Switch1, сегмента серверов. Логинимся в режим глобальной конфигурации.

Закинем порты fa 0/1-2 в VLAN4

Настроим trunk порт fa 0/3, разрешать будем только трафик vlan4

Настройка Switch2

Все с сегментом серверов мы закончили. Переходим к такой же настройке на Switch2 и 3. И так Switch2 Cisco 2960.

Первым делом создаем vlan 2 и vlan3.

Теперь определим наши порты в которые подключены компьютеры в нужные vlan

Настроим trunk порт на интерфейсе fa 0/3

Читайте также:  D link des 1016d сброс настроек

Настройка Switch3

Тот же фокус проводим с настройкой Switch3 Cisco 2960

Первым делом создаем vlan 2 и vlan3.

Теперь определим наши порты в которые подключены компьютеры в нужные vlan

Настроим trunk порт на интерфейсе fa 0/3

Настройка ядра сети

Приступаем к настройке маршрутизации, на ядре Cisco 3560, все три его порта нужно настроить как trunk, создать vlan и назначить им ip.

создаем vlan 2,3,4
vlan 2
name VLAN2
exit
vlan 3
name VLAN3
exit
vlan 4
name VLAN4
exit

Задаем статический ip адрес vlan2,3,4

int vlan 2
ip address 192.168.1.251 255.255.255.0
no shutdown
exit
int vlan 3
ip address 192.168.2.251 255.255.255.0
no shutdown
exit
int vlan 4
ip address 192.168.3.251 255.255.255.0
no shutdown
exit

Настраиваем trunk порты

int fa 0/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 2,3
exit
int fa 0/2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 2,3
exit
int fa 0/3
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 2,3
exit

Включаем маршрутизацию и сохраняем конфигурацию
ip routing
do wr mem

Ping будет производиться с компьютера PC3. Как видим, сервера и обычные компьютеры разделены.

О настройке интернета и NAT поговорим в следующих статьях на данную тему. Как видите конфигурирование маршрутизаторов cisco, не такое уж и сложное дело.

Источник

Маршрутизатор Cisco — начальная настройка

При первоначальной настройки маршрутизатор cisco необходимо подключить к COM порту компьютера, посредством специального консольного кабеля.

Кабель представляет собой с одной стороны разъём DB9 (female/мама) для подключения к COM порту компьютера, а с другой RJ-45 для подключения к консольному порту маршрутизатора (порт обведён в голубой цвет и имеет надпись Console, либо просто надпись Console на голубом фоне).

Консольный кабель Cisco

Консольные порты Cisco

Новые модели маршрутизаторов, например Cisco 2900 Series Integrated Services Routers (ISR), имеют как RJ-45 консольный порт, так и консольный порт mini-USB Type B.

Mini-USB порт позволяет подключаться к консоли через USB кабель, если вдруг в компьютере отсутствует COM порт. Если настройка роутера производится через USB кабель на компьютере с Microsoft Windows, на компьютер необходимо установить драйвер Cisco Microsoft Windows USB Device Driver.

Кабель Mini USB

Консольный порт USB имеет приоритет над RJ-45. При настройке одновременное использование консольных портов не допускается.

Для настройки устройства через консольный кабель на компьютере с Microsoft Windows можно использовать встроенную программу Hyper Terminal, для меня она не очень удобна, поэтому я использую Putty (возможно это просто дело привычки). В программе, будь то Putty, Hyper terminal или ещё какая-либо, необходимо настроить параметры порта (COM) следующим образом:

Скорость (бит/с): 9600

Стоповые биты: 1

Управление потоком: нет

Пример настройки в Putty:

Настройка COM порта в Putty

После чего, если маршрутизатор включен и соединен с компьютером консольным кабелем, в окне терминала (по нажатию на Enter) появится интерфейс командной строки. Так же здесь можно наблюдать и процесс загрузки устройства.

Можно приступать к настройке устройства.

Логин/пароль по умолчанию обычно либо cisco/cisco либо пустой пароль на вход в привилегированный режим.

Входим в привилегированный режим командой «enable»:

Очищаем существующую конфигурацию командой «erase startup-config»:

Router#
Router#erase startup-config
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: complete
Router#
*Mar 1 00:10:46.519: %SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram
Router#

Перезагружаем роутер командой «reload» и подтверждаем её:

Router#reload
Proceed with reload? [confirm]

*Mar 1 00:14:52.907: %SYS-5-RELOAD: Reload requested by console. Reload Reason: Reload command.

Так как мы стерли конфигурационный файл startup-config, то после перезагрузки предлагается пройти мастер начальной настройки системы, в котором предлагается вести имя маршрутизатора, пароли для различных режимов, IP адрес на интерфейсе управления и прочее. Я обычно на запрос запуска мастера отвечаю: no , а все необходимые параметры ввожу вручную.

Читайте также:  Netbynet настройка роутера huawei

Пишем no и жмём Enter.

Переходим в режим глобального конфигурирования системы командой «configure terminal» (сперва не забываем перейти в привилегированный )

Router>
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#

Видно как изменилась строка приглашения на «Router(config)# » — означает, что мы находимся в глобальном режиме конфигурации системы

Задаём пароль на вход в привилегированный режим командой «enable secret»

Router(config)#enable secret 0 pass123
Router(config)#

0 — означает ввод пароля в не зашифрованном виде, но храниться будет он в шифрованном.

pass123 — сам пароль

Устанавливаем имя маршрутизатора командой «hostname»

Задаём имя домена командой «ip domain-name»

RTR1(config)#
RTR1(config)#ip domain-name test.ru
RTR1(config)#

Прописываем время, дату и часовой пояс. Задать время и дату можно просто в привилегированном режиме, не переходя в режим глобального конфигурирования системы, а вот часовой пояс только в режиме конфигурации.

Время и дата командой «clock set» (например 26 марта 2013 года, 19 часов 32 минуты 30 секунд):

RTR1#
RTR1#clock set 19:32:30 26 Mar 2013
RTR1#

Часовой пояс командой «clock timezone» (например смещение по UTC в +10 часов):

RTR1#
RTR1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
RTR1(config)#
RTR1(config)#clock timezone YST 10
RTR1(config)#

Включаем аутентификацию и заводим пользователя.

RTR1(config)#
RTR1(config)#aaa new-model
RTR1(config)#aaa authentication login default local
RTR1(config)#

Команда «aaa new-model» — активирует возможность использования функций и команд для аутентификации, авторизации, аккаунтинга (AAA)

Команда «aaa authentication login default local» — включает аутентификацию при попытке сделать logon, и проверяет пользователя и пароль по локальной базе.

После ввода этих команд, нужно создать пользователя, иначе нельзя будет зайти на маршрутизатор ни по ssh/telnet, ни через консоль.

Создаём пользователя petya с паролем password123:

RTR1(config)#
RTR1(config)#username petya secret 0 password123
RTR1(config)#

Настраиваем сетевой интерфейс. Что бы настроить сетевой интерфейс, нужно перейти из режима глобального конфигурирования в режим конфигурирования интерфейса.

RTR1(config)#
RTR1(config)#interface fastEthernet 0/0
RTR1(config-if)#ip address 192.168.56.254 255.255.255.0
RTR1(config-if)#no shutdown
RTR1(config-if)#
RTR1(config-if)#
Mar 26 19:51:11.851: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
Mar 26 19:51:12.851: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
RTR1(config-if)#
RTR1(config-if)#exit
RTR1(config)#

Команда «interface fastEthernet 0/0» — переводит в режим конфигурирования интерфейса. В данном случае у нас интерфейс называется «fastEthernet «, в зависимости от модели роутера, могут быть другие названия например ethernet или gigabitEthernet. Информацию о состоянии интерфейсов можно посмотреть командой «show interfaces»

Команда «ip address 192.168.56.254 255.255.255.0» — задаёт IP адрес и сетевую маску на интерфейсе

Команда «no shutdown» — включает интерфейс

Команда «exit» — производит выход из режима конфигурации интерфейса в глобальный режим конфигурации.

Разрешаем удаленный доступ к устройству по telnet или ssh. Не все версии IOS поддерживают ssh (необходима поддержка шифрования). Поэтому в некоторых случаях приходится настраивать удаленный доступ и для telnet. Для настройки ssh необходимо сперва сгенерировать ключи.

Генерируем ключи командой «crypto key generate rsa»:

RTR1(config)#
RTR1(config)#crypto key generate rsa
The name for the keys will be: RTR1.test.ru
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.

How many bits in the modulus [512]:
% Generating 512 bit RSA keys . [OK]

RTR1(config)#
Mar 26 20:16:47.879: %SSH-5-ENABLED: SSH 1.5 has been enabled
RTR1(config)#

Как только сгенерировались ключи, в консоли вышло сообщение, что ssh включен. Кстати, для генерации ключей необходимо сперва задать имя домена и желательно выставить правильное время, что я уже сделал выше.

Читайте также:  Подключение роутера асус и его настройка

Разрешаем ssh и telnet на линиях виртуальных терминалов:

RTR1(config)#
RTR1(config)#line vty 0 4
RTR1(config-line)#transport input telnet ssh
RTR1(config-line)#exec-timeout 60
RTR1(config-line)#
RTR1(config-line)#exit
RTR1(config)#

Команда «line vty 0 4» — переводит в режим конфигурирования линий VTY с 0 по 4

Команда «transport input telnet ssh» — разрешает вход через telnet и ssh на терминалы vty

Команда «exec-timeout 60» — отключает от линии пользователя после 60 минут бездействия

команда «exit» — выход из режима конфигурировании линий в глобальный режим.

В данном случае разрешён удаленный доступ с любых IP адресов, что бы ограничить, необходимо создавать ACL и вешать их на линии.

Сохраняем конфигурацию. Всё, что мы сейчас настроили будет работать до первой перезагрузки. Что бы конфиг сохранился его нужно сохранить командой «copy running-config startup-config»:

RTR1(config)#exit
RTR1#copy running-config startup-config
Building configuration.
[OK]
RTR1#

Источник

Настройка роутера cisco 3925

Сообщения без ответов | Активные темы Текущее время: 10 ноя 2020, 12:43

Часовой пояс: UTC + 3 часа

Cisco ASA и Cisco 3925

Страница 1 из 1 [ Сообщений: 19 ]
Версия для печати Пред. тема | След. тема

ro.dubovik
Провайдеров в итоге сколько планируется?
Если два, то в каком режиме будут работать — active/active или active/standby?

Пока не очень понятно техническое задание (то, что Вам нужно), но общий вариант такой:
Core(Cisco Catalyst 3750) — inside outside — Border router (Cisco 3925) — ISP 1,2.

ro.dubovik
Провайдеров в итоге сколько планируется?
Если два, то в каком режиме будут работать — active/active или active/standby?

Пока не очень понятно техническое задание (то, что Вам нужно), но общий вариант такой:
Core(Cisco Catalyst 3750) — inside outside — Border router (Cisco 3925) — ISP 1,2.

Спасибо конецно всем за объективность. Ну да, новичок. Брали на админа, планировали взять ведущего, который занимался цисками, но потом передумали, так что выхода особо нет.

Провайдеров 2, задания конкретного нет, у руководства главное, что б инет был быстрый.
Я пока у себя в голове выбрал схему при которой все внешние сервисы, как почта, видеоконференция с районами, остануться как и прежде пока на 1 провайдере и ломать ничего не хочется, а какой то сегмент сети или основной, пользовательский влан будет ходить через 2 провайдера.

Core(Cisco Catalyst 3750) — inside outside — ISP 1 (так сейчас)
Core(Cisco Catalyst 3750) — inside outside — ISP 2

Подсказывали, что сегмент роутмэпом делать.
Пока в голове одна идея, после просмотра конфигов роутера и ядра такая:
На роутере висят тунели с районами, на всех серваках указан шлюзом непосредственно роутер(Cisco 3925),
в dhcp раздается адрес ядра сети (каталиста), с каталиста идет ip route на роутер(Cisco 3925).

Я думаю поменять ip route на асу, так я думаю все будут ходить через 2 провайдера, будут видеть внутреннюю сеть, а серваки и тунели остануться на роутере. Так же хотел услышать предложения, как можно более безболезненно перейти на схему указанную выше
Core(Cisco Catalyst 3750) — inside outside — Border router (Cisco 3925) — ISP 1,2.

И пожалуйста без злорадства, я может плоховато представляю себе маршрутизацию, но что такое сеть, схема сети и конфиги вполне представляю, за то что у меня мало опыта и плоховато выражаюсь — прошу меня извинить, собстенно за этим и пришел.
AntiCisco Все, что Вы хотели узнать про CISCO, но не знали, где спросить.

ntv83 спасибо за конструктив!

Извини за выражение, под левым вланом подразумевал, отдельную, ни с чем не связанную подсеть

Источник