Меню

Настройка wifi mikrotik в режиме клиента



Mikrotik: настройка интернета

Настройка интернета на роутерах Mikotik для простого пользователя задача непростая. Роутер Mikrotik снабжен своей собственной OC с интерфейсом на базе Linux. Здесь нет простых настроек, которые все привыкли видеть в большинстве роутеров, предназначенных для дома или малого офиса. Но для быстрой и более удобной настройки подключения роутера к интернету можно воспользоваться функцией «QuickSet».

Освоить MikroTik Вы можете с помощью онлайн-куса « Настройка оборудования MikroTik ». Курс основан на официальной программе MTCNA. Автор курса – официальный тренер MikroTik. Подходит и тем, кто уже давно работает с микротиками, и тем, кто еще их не держал в руках. В курс входит 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект.

Для подключения к роутеру будем использовать программу WinBox, которую можно скачать с официального сайта http://www.mikrotik.com/download/winbox.exe .

Переходим на вкладку Neighbors, выбираем устройство и жмем Connect.

При первом входе в интерфейс роутера появится предложение установить конфигурацию по умолчанию либо удалить ее. Рекомендую воспользоваться удалением базовыхнастроек и настроить все с нуля.

Если диалогового окна для сброса настроек при входе нет, то настройки можно сбросить здесь «System\Reset Configuration«. Обязательно ставим галочку на пункте «No Default Configuration«, чтобы после сброса не применялась настройка по умолчанию.

Быстрая настройка интернета с помощью QuickSet.

В мастере быстрой настройки «Quick Set» предусмотрено несколько режимов работы роутера:

  • CAP: Контролируемая точка доступа, которая управляется CAPsMAN сервером
  • CPE: Режим клиента, который подключается к точке доступа AP.
  • Home AP: Домашняя точка доступа. Этот режим подходит для упрощенной настройки доступа к интернету.
  • PTP Bridge AP: Создает точку доступа для подключения к ней удаленного клиента
    PTP Bridge CPE и создания единой сети.
  • PTP Bridge CPE: Клиент для подключения к удаленной точки доступа PTP Bridge AP.
  • WISP AP: Режим похожий на Home AP, но предоставляет более продвинутые возможности.

Выбираем режим Home AP и приступаем к настройке роутера в качестве обычной точки доступа к интернету, которую можно использовать для небольшого офиса и дома.

Настраиваем WiFi.

Network Name: Название сети. Это название будут видеть тот кто подключается к вашей сети по WiFi.

Frequency: в обычной ситуации лучше оставить значение Auto. роутер сам подберет оптимальную частоту работы.

Band: Диапазон частот для домашнего роутера 2GHz-only-N. Если в сети есть старые устройства, работающие по протоколам 802.11b или 802.11g, тогда нужно будет выбрать режим 2GHz-B/G/N, но будет потеря в скорости соединения.

Use Access List (ACL): Используется для того чтобы ограничить доступ по WiFi. Прежде чем включать эту опцию необходимо создать список клиентов, которым разрешен доступ. Выбираем из списка подключенных клиентов и нажимаем кнопу Copy To ACL.

В обычной ситуации этой функцией лучше не пользоваться т.к. аутентификация по паролю обеспечивает достаточные ограничения.

WiFi Password: укажите здесь пароль для подключения к роутеру по WiFi.

WPS Accept: эта кнопка используется для упрощенного подключения устройств, которые поддерживают режим WPS. Такими устройствами могут быть принтеры или видеокамеры, на которых затруднен ввод пароля вручную. В первую очередь включить WPS нужно на подключаемом устройстве, а затем нажать кнопку роутера «WPS Accept».

Guest Network: эта функция позволяет создать отдельную гостевую сеть WiFi. Те, кто подключаются через гостевой WiFi, не будут иметь доступа к вашему роутеру, локальной сети и устройствам, находящимся в ней. Используйте гостевую сеть для повышения сетевой безопасности.

Задайте пароль в поле «Guest WiFi Password» и ограничение скорости на скачивание «Limit Download Speed«

Wireless Clients: здесь можно увидеть подключенные
в данный момент по WiFi устройства. В таблице показан MAC-адрес, IP-адрес, продолжительность подключения, качество сигнала и ACL (список разрешенных устройств)

Настраиваем интернет.

Здесь мы указываем те параметры подключения, которые нам передал провайдер интернета.

Port: Указываем физический порт, к которому подключен кабель провайдера

Adress Acquisition: указывем способ получения IP адреса. В моем случае адрес статический. При PPPoE подключении указываем логин, пароль и адрес pppoe-сервера.

MAC Address: физический адрес устройства, который будет видеть провайдер. Имеет смысл менять если вы Mikrotik ставите вместо другого роутера, а у провайдера на маршрутизаторе установлена привязка по mac-адресу.

MAC server / MAC Winbox: позволяет подключаться к роутеру используя его mac-адрес. Может пригодится при отладке или восстановлении, когда роутер недоступен по ip-адресу.

Discovery: позволяет распознавать роутер другими роутерами Mikrotik.

Настройка локальной сети.

IP Address: указываем ip-адрес устройства в нашей локальной сети.

Netmask: маску оставляем наиболее распространенную для большинства случаев 255.255.255.0.

Bridge All LAN Ports: объединяем все порты роутера в общий коммутационный узел, позволяя всем подключенным устройствам находится в одной сети и обнаруживать друг друга.

DHCP Server: включаем сервер автоматической раздачи ip-адресов устройствам, подключенным к роутеру.

Читайте также:  Модем м200 в настройка wifi

NAT: должен быть включен для трансляции ip-адресов из локальных в публичные, иначе устройства локальной сети не получат возможность выйти в интернет.

UPnP: эту опцию лучше не активировать, если нет необходимости т.к. она позволяет выполнять автоматический проброс стандартных локальных портов в интернет. Порты лучше пробрасывать вручную, чтобы злоумышленники не знали их адреса.

Настройку VPN рассматривать в рамках данной статьи не будем. Отмечу лишь, что она так же доступна в QuickSet и может пригодится тем, кто использует VPN-туннели для объединения нескольких локальных сетей или устройств в одну частную сеть через интернет.

Настройка интернета вручную.

Настройка провайдера интернета на роутере Mikrotik вручную предполагает наличие у вас необходимых знаний в области сетевых технологий и более детального знания интерфейса Router OS и его консоли.

Сбрасываем настройки роутера в System > Reset Configuration .

Переименуем порт в списке интерфейсов «ether1-WAN«, чтобы сразу было понятно к какому порту подключен провайдер.

Вариант для любителей консоли:

Меняем MAC-адрес если до Mikrotik работал другой роутер, а провайдер интернета сделал привязку на своем маршрутизаторе к mac-адресу. Вместо нулей пишите mac своего старого роутера.

Настройка WiFi.

Открываем в меню пункт Wireless, выбираем WiFi интерфейс и включаем, нажав галочку, если он неактивен.

Заходим в настройки интерфейса двойным кликом и выбираем вкладку Security Profiles. Создаем свой профиль или редактируем существующий.

  • Authentication Types: способ идентификации выбираем WPA2 PSK — он более надежен чем WPA, EAP — использует проверку подлинности внешнем сервером, актуален для корпоративных сетей;
  • Unicast Ciphers и Group Ciphers: тип шифрования включаем aes com — это более современный и быстрый тип шифрования, tkip стоит включать если на каком-то устройстве, вероятно устаревшем, возникают проблемы с подключением;
  • WPA2 Pre-Shared Key: задаем пароль для подключения к точке доступа WiFi.

Переходим на вкладку WiFi interfaces. В настройках беспроводного интерфейса, во вкладке Wireless прописываем следующие настройки для WiFi:

  • Mode: ap bridge, включаем режим точки доступа;
  • Band: 2GHz-only-N, этот способ вещания лучше всего подходит для большинства современных беспроводных устройств;
  • Frequency: Auto, режим автоматического выбора частоты вещания;
  • SSID: Вводим название беспроводной сети;
  • Wireless Protocol: 802.11;
  • Security Profile: default, выбираем тот который настроили ранее.

Настройка локальной сети.

Первый порт подключен к провайдеру. Оставшиеся порты будут использоваться для подключения устройств локальной сети. Для того чтобы порты находились в одной физической сети и могли коммутировать подключения их необходимо объединить в мост.

Создаем мост.

Для создания моста переходим в Bridge. Нажимаем плюсик и вписываем название моста, например «bridge-local».

Добавляем в мост порты. Открываем вкладку Ports. Жмем плюс и один за другим добавляем все порты, кроме того к которому подключен интернет, в мост bridge-local.

/interface bridge port
add bridge=bridge-local interface=ether2
add bridge=bridge-local interface=ether3
add bridge=bridge-local interface=ether4
add bridge=bridge-local interface=ether5
add bridge=bridge-local interface=wlan1

Присваиваем мосту IP-адрес. Пункт меню IP > Adresses.

Теперь у нас все порты, включая WiFi, закоммутированны и могут пересылать пакеты между собой. Остается настроить шлюз выхода в интернет.

Включаем сервер DHCP.

Определяем пул ip-адресов, которые будет раздавать DHCP server устройствам локальной сети. Выбираем в меню пункт IP/Pool. Через плюсик добавляем новый пул, вводим название и диапазон адресов.

Переходим к включению DHCP сервера IP > DHCP Server. Создаем новый DHCP сервер, указываем имя, интерфейс и пул адресов.

Во вкладке Networks указываем настройки, которые сервер будет передавать своим клиентам: адрес сети, маску сети, шлюз и DNS серверы. Маску лучше указывать сразу после адреса, через слеш.

После того как мы подготовили локальную сеть, можно перейти к настройке шлюза для выхода в интернет.

Настройка интернета.

Настройка подключения к интернету зависит от способа, предоставленного вам провайдером. Наиболее распространенный способ без использования статического ip адреса — подключение по технологии PPPoE. Так же рассмотрим часто используемые варианты с выделенным IP и динамическим получением IP-адреса от DHCP провайдера.

Подключение к провайдеру по PPPoE.

Открываем PPP и создаем новое соединение PPPoE Client. Интерфейс выбираем тот куда подключен провод провайдера.

На вкладке Dial Out вписываем имя и пароль для подключения. Отмечаем галочкой пункт Use Peer DNS, который обозначает что адреса DNS серверов будем получать от провайдера. Add Default Route добавляет маршрут, используемый по умолчанию, в таблицу маршрутизации.

Подключение к провайдеру по технологии PPTP или L2TP происходит способом аналогичным PPPoE. Разница лишь в том, что при добавлении PPTP Client или L2TP Client во вкладке Dial Out необходимо указать, помимо логина и пароля, адрес сервера.

Подключение по статическому IP.

Для образца возьмем такие параметры подключения, полученные от провайдера:
Адрес: 10.20.30.41
Маска: 255.255.255.248
Шлюз: 10.20.30.42
Для DNS используем серверы Google: 8.8.8.8, 8.8.4.4

Читайте также:  Настройка wifi модема стрим

Настраиваем IP-конфигурацию интерфейса, к которому подключен провод провайдера: IP > Adresses.

Добавляем маршрут для пакетов, направленных в интернет: IP > Routes. Адрес назначения для пакетов интернета Dst. Address: 0.0.0.0/0, шлюз Gateway: 10.20.30.42. Включаем проверку доступности шлюза Check Gateway: ping.

Добавляем адреса DNS-серверов. IP > DNS.

Настройка подключения по DHCP.

Этот вариант самый простой по настройке. Переходим IP > DHCP Client. Указываем интерфейс, подключенный к провайдеру. Остальные настройки оставляем как есть.

Отмеченные галочками Use Peer DNS и Use Peer NTP означают полчения от провайдера адресов DNS сервера и сервера синхронизации времени NTP. Add Default Roue добавляет маршрут, используемый по умолчанию, в таблицу маршрутизации.

После настройки подключения к провайдеру необходимо выполнить настройку NAT. NAT выполняет трансляцию локальных ip-адресов в публичный адрес, предоставленный провайдером. Если этого не сделать, то трафик в интернет уходить не будет.

Настройка NAT.

Добавляем в NAT правило трансляции локальных адресов.

IP > Firewall > Nat. Добавляем новое правило. Указываем, что трафик исходящий Chain: srcnat. Выбираем интерфейс исходящего трафика Out. Interface: Ether1-WAN или pppoe-out1, в зависимости от настройки подключения к провайдеру.

Далее переключаемся на вкладку Action и выбираем masquerade.

Теперь во всем трафике, идущем в интернет, локальные адреса преобразуются в публичный адрес провайдера и сервера-адресаты знают куда отвечать. А это значит, что интернет должен работать.

Остается один не менее важный вопрос — это безопасность вашего роутера. Для предотвращения взлома вашего роутера необходимо настроить Firewall. О том, как это сделать, читайте здесь.

Освоить MikroTik Вы можете с помощью онлайн-куса « Настройка оборудования MikroTik ». Курс основан на официальной программе MTCNA. Автор курса – официальный тренер MikroTik. Подходит и тем, кто уже давно работает с микротиками, и тем, кто еще их не держал в руках. В курс входит 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект.

Источник

Настройка MikroTik cAP Lite как Wi-Fi клиент в режиме Bridge

Сегодня я расскажу Вам, как настроить маленькую клиентскую точку MikroTik cAP Lite.
Она будет подключаться к домашнему Wi-Fi и предоставлять локальную сеть и интернет SMART телевизору, который будет к ней подключен по Ethernet кабелю.

1. Вступление
Побывав как-то раз на MUM в Москве. Мне посчастливилось получить в подарок такую штуку, как cAP Lite. Чертовски приятно, я хочу Вам сказать =)
Плюсом был еще некоторый “Мерч”, но это к данной теме не относится.

Давайте кратко рассмотрим само устройство.
Код продукта: RBcAPL-2nD
Архитектура: MIPSBE
CPU: QCA9533 (1 ядро, 650 MHz) – он же для Wi-Fi
Оперативной памяти: 64 Мб
Места на FLASH накопителе: 16 Мб
Температурный диапазон: от -40°C до +70°C
Максимальное потребление: 4Вт
Питание: microUSB type AB 5V(0,2A), PoE-In 10-60V
Wi-Fi: Каналов 2, Частота 2.4GHz, 802.11 b/g/n
Базовое усиление антенн: 1.5 dBi
Порт Ethernet: 10/100 Мбит/сек

По результатам теста самого Mikrotik, данное устройство не выдает более 98 Мбит на блоках 1518 байт.
Мои тесты в Btest(UDP, Random Data) показали такие значения:
Receive Send Ну а Both я думаю можно себе представить

В целом устройство компактное и его можно расположить скрытно, чтобы не мешало.

2. Настройка cAP Lite
Я буду рассматривать подключение к своей домашней сети.
Создание домашней сети на базе устройств MikroTik: Часть 1
cAP Lite должен подключиться к сети и далее работать в режиме сетевого моста, чтобы телевизор мог получить IP адрес от роутера и выйти в интернет.

Для начала подключим питание через USB порт и подключим cAP Lite, сетевым кабелем к нашему ПК.
Запускаем уже привычный нам WinBox. (Для тех кто пропустил: Знакомимся с интерфейсом WinBox)
Находим наше устройство в Neighbors и подключаемся по MAC адресу.
Обновите cAP Lite до последней версии прошивки из ветки Bugfix. На момент написания статьи у меня была версия 6.40.7

Сброс базовых настроек
Консольно:
/system reset-configuration no-defaults=yes skip-backup=yes

После перезагрузки, подключаемся повторно по MAC адресу.
Я дополнительно устанавливаю пакет MULTICAST для его поддержки. Вы же, не обязаны этого делать.
Ставить или не ставить данный пакет решать Вам. Его можно найти, если скачать архив Extra packages с сайта MikroTik.
Он нужен если Вы решите пустить IPTV(igmp) трафик внутрь локальной сети не только по кабелям, но и по Wi-Fi.
Установка пакета выполняется простым перетаскиванием его в File List интерфейса WinBox и последующей перезагрузкой cAP Lite.

Настройка сетевых интерфейсов
Открываем вкладку Interfaces и переходм к настройке каждого интерфейса
У нас присутствует всего два интерфейса: ether1 и wlan1
Начнем с сетевого интерфейса ether1:
Консольно:
/interface set ether1 name=»LAN1-Master»

Перед тем, как перейти к настройке Wi-Fi интерфейса wlan1, необходимо установить пароль для Wi-Fi сети, к которой будет подключаться cAP Lite.
Это делается в меню Wireless:
Консольно:
/interface wireless security-profiles
set default mode=dynamic-keys authentication-types=wpa2-psk unicast-ciphers=aes-ccm group-ciphers=aes-ccm wpa2-pre-shared-key=»password»

Читайте также:  Zyxel keenetic giga iii настройка wifi

Теперь настроим сам wlan1 интерфейс:
Вкладка General для wlan1 интерфейса Вкладка Wireless

А почему MODE = station pseudobridge ?
Чтобы это понять, немного погрузимся в каждый режим…
Выдержка из: wiki.mikrotik.com – Wireless Station Modes: Mode_station
Матрица применимости:

802.11 ROS 802.11 nstreme nv2
station V V V V
station-wds V V V
station-pseudobridge V V V
station-pseudobridge-clone V V V
station-bridge V V V
  1. station
    Это стандартный режим, который не поддерживает прохождение L2 трафика – попытки установить беспроводной интерфейс в Bridge не приведут к ожидаемым результатам. С другой стороны, этот режим можно считать наиболее эффективным, и поэтому его следует использовать, если нет необходимости гонять L2 трафик через данного Wi-Fi клиента до конечных устройств или служб.
  2. station-wds
    Этот режим работает только с точками доступа RouterOS. В результате согласования соединения на AP для данной станции создается отдельный интерфейс WDS. Этот режим безопасен для прохождения трафика L2 и дает более гибкий административный контроль на точке доступа, к которой подключается клиент, с помощью отдельного интерфейса WDS, например, можно использовать межсетевой экран Bridge.
    В режиме station-wds невозможно подключиться к CAP, управляемой CAPsMAN!
  3. station-pseudobridge
    С точки зрения беспроводного соединения этот режим такой же, как и режим station. Он имеет ограниченную поддержку прохождения L2 трафика с помощью некоторых служб, реализованных на точке доступа, к которой подключается клиент.
    Суть данного режима в преобразовании MAC-адресов для пакетов IPv4. Wi-Fi клиент поддерживает таблицу сопоставления IPv4-MAC и заменяет исходный MAC-адрес своим собственным адресом при отправке кадра в точку доступа. Т.е. этот режим существенно ограничен.
    Доступен для всех протоколов, кроме nv2, и его следует по возможности избегать. Использование этого режима может быть оправдано только в том случае, если точка доступа не поддерживает лучший режим для моста L2 (например, когда используется точка доступа, отличная от RouterOS) или если только одно устройство конечного пользователя должно быть подключено через Wi-Fi клиент.
  4. station-pseudobridge-clone
    Этот режим аналогичен режиму station-pseudobridge, за исключением того, что он подключается к точке доступа с использованием «клонированного» MAC-адреса – это либо адрес, настроенный в параметре station-bridge-clone-mac, либо адрес источника первого перенаправленного кадра.
  5. station-bridge
    Этот режим работает только с точками доступа работающих под управлением RouterOS. Он обеспечивает поддержку прозрачную, независимую от протокола, пересылку трафика L2.
    В этом режиме, точка доступа, поддерживает таблицу пересылки с информацией о том, какие MAC-адреса доступны и через какие Wi-Fi клиенты.
    Этот режим является собственностью MikroTik и не может использоваться для подключения к устройствам других марок.
    Этот режим безопасен для пересылки L2 трафика и является предпочтительным режимом, если нет особых причин использовать режим station-wds.
    В режиме station-bridge невозможно подключиться к CAP, контролируемой CAPsMAN!

Т.е. выбора особого не было с учетом того, что подключал я свой cAP Lite к роутеру ASUS. Я решил использовать ограниченный функционал прохождения L2 трафика.
Если вы подключаете Wi-Fi клиента к устройству MikroTik работающему на RouterOS, то используйте mode = station-bridge (!)

Вкладка Advanced Консольно:
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode band=2ghz-onlyn channel-width=20/40mhz-Ce country=romania disabled=no distance=indoors frequency=auto frequency-mode=regulatory-domain hw-protection-mode=rts-cts mode=station-pseudobridge multicast-helper=full name=LAN2-wifi24ghz radio-name=MYWIFI-SSEAA13 ssid=MYWIFI wireless-protocol=802.11 wmm-support=enabled wps-mode=disabled hw-retries=15 disconnect-timeout=15s on-fail-retry-time=1s
/interface wireless nstreme
set LAN2-wifi24ghz enable-polling=no

Теперь нам нужно подключить cAP Lite к нашей Wi-Fi сети:
Консольно:
/interface wireless connect-list
add interface=LAN2-wifi24ghz security-profile=default ssid=MYWIFI wireless-protocol=802.11

Настройка сетевого моста
Для того, чтобы все работало корректно и данные “ходили” между проводным интерфейсом и Wi-Fi интерфейсом, нам необходим сетевой мост (Bridge)
Создаем Bridge интерфейс:
Консольно:
/interface bridge
add name=»LAN-Bridge» comment=»LAN» mtu=1500 fast-forward=no igmp-snooping=yes protocol-mode=none

Добавляем интерфейсы в порты нового Bridge
Консольно:
/interface bridge port
add bridge=LAN-Bridge interface=LAN1-Master
add bridge=LAN-Bridge interface=LAN2-wifi24ghz

Получение IP адреса
Получим IP адрес для нашего Wi-Fi моста. Мне нужен удаленный доступ к этому устройству.
Для этого настраиваем DHCP Client
После всех настроек мы должны корректно получать IP адрес от нашего роутера.
Консольно:
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=LAN-Bridge use-peer-ntp=no

3. Заключение
Рабочая конфигурация На этом, в принципе, основные настройки закончены.
Остается еще ряд мелочей, вроде включения SNMP протокола, для мониторинга с помощью DUDE и некоторые другие индивидуальные настройки.

Надеюсь данное руководство оказалось Вам полезным. Благодарю за Ваше время.

По любым дополнениям к данной статье, различным вопросам, просьба писать ниже в комментариях =)
До новых статей!

Список всех статей в хронологическом порядке: История статей

UPD: 30.11.2018
Добавлены настройки Wireless Advanced в части уменьшения разрывов соединения (data loss)

UPD: 30.11.2019
Добавлена информация по выбору Mode на вкладке Wireless. Почему все таки station-pseudobridge?

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

Источник

Adblock
detector